Why Are My Plugins Not Showing In My Dashboard?

A common complaint about WordPress is that after uploading plugins to your server they do not show up in WordPress. But what is really going on?

If you don’t have WordPress 2.7

Make sure you’re uploading to the correct folder. This should be wp-content/plugins.
Make sure the files have uploaded. There should be no Failed Transfers listed in Filezilla and you can see the files on your server.
Make sure the plugin is not in a zip folder. Most plugins are downloaded zipped, you need to upzip the zip folder contents before uploading.
Make sure there are some files in the top level folder. Some plugins have a folder, then inside that no files, just another folder. WordPress will not see these files if there is no file in the top level folder.

A great video found on YouTube shows you how to upload a plugin:

If you have WordPress 2.7 or above

Then to avoid these issues you can use the inbuilt plugin uploader. Go to Plugins > Add New. There you can search for a plugin and if it’s in the WordPress repository you can install it then and there. If not you can upload the zip file from the site you have downloaded it from and it will install that for you.

Hopefully the next version of WordPress will allow a similar action for installing new WordPress Themes, as it’s a great feature to avoid the frustration many bloggers have with installing plugins.

4 thoughts on “Why Are My Plugins Not Showing In My Dashboard?”

  1. Hi
    I have wordfence security installed and you can see it on the server but not in the plugin directory.
    All other plugins are fine except this one.
    I have updated WordPress to the latest version but this time I had to do it manually as the auto updat didnt work.
    the hosting company says there is nothing wrong there end – very strange.
    Could the site be hacked??
    do you have any advice for me to fix this.
    i did try deleting wordfence and manually installing it via ftp – but it still does the same thing.

    This is the website.
    sydneywellbeing.com/

    Thanks Jodi

    1. I think contacting Wordfence would be your best bet as without looking at your server myself there’s no way to tell what might be causing this for you. I hope you can get it fixed soon!

    2. Thanks Joel – the problem was my client had WordPress in a folder and not in the root.
      A simple re-direct in the wp config file fixed it. Just thought I’d let you know, in case someone else has the same problem.
      Thanks for your response.
      Jodi

Leave a Reply